Hello,
If we want to make the sip-router core usable in both projects, we would also
need to merge both tls implementations. In SER we moved the the TLS
implementation into tls module.
In Kamailio it appears that the tls implementation is in tls subdirectory in
the core and then there is tlsops module which contains pseudovariables used
to retrieve information from TLS certificates.
Unless somebody has a better idea, I would propose that we merge the tls
implementation from kamailio core into ser tls module. In addition to that we
could merge the implementation of tls related pseudovariables from tlsops into
the tls module and then put the tls module into the sip-router repository.
What do you think? I volunteer to do this if nobody objects.
Jan.
Hi *,
Do you know of some dns server having some EBL records, that I can use
for testing? (just a few queries)
I'm writing right now EBL support for sip-router (the main differences
from k are that dns caching EBLs is supported too and this requires a
more compact structure without fixed size arrays).
BTW: there seem to be 2 small bugs in the k code:
dns_ebl_parser(...):
1.
len = *rdata;
^^^^^^^^^^^^ this is the position and not the len
if (rdata + 1 + len >= end)
^^^^^^^^^^^^^^^^^^^^^^^^^^ len being the position this is useless
it should be something like:
if (((rdata+4)>end)||((rdata+1+1+rdata[1]+2)>end)) goto error;
(4 being the minimum size for an ebl and the other expression
being ebl with minimum apex)
2.
ebl->apex_len=dn_expand(msg, end, rdata, ebl->apex, MAX_DNS_NAME-1);
^^^^^^^^^ dn_expand returns the compressed len so this should
be replaced by ebl->apex_len=strlen(ebl->apex).
Also why >= instead of >?
Andrei
Module: sip-router
Branch: master
Commit: a633737cf21a9581f1238067ba6c331bad93ab85
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=a633737…
Author: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Committer: Andrei Pelinescu-Onciul <andrei(a)iptel.org>
Date: Tue Mar 31 19:26:41 2009 +0200
Merge branch 'ser_core_cvs' of ssh://git.sip-router.org/sip-router
* 'ser_core_cvs' of ssh://git.sip-router.org/sip-router:
dns: minor fixes
Static buffer is resetted before calling the route block -- Thanks to Jan.
Missing include is added.
Conflicts:
modules/tm/t_suspend.c : sip-router version uses
i run_top_route()
---
Hi,
attached patch fixes the msg_send usage for the utils module. It uses the
forward_request function, instead of doing it manually with msg_send. Its
against the kamailio-3.0 repository.
I also attached a patch that implements a mk_proxy in shared memory and the
necessary utility functions. The kamailio implementation used to allocates
fewer parts of the struct. I simply did a replace for /pkg_/shm_/ on the
existing proxy implementation, so suggestions for improvements are welcome.
This patch is against the sr core, but perhaps its more appropriate to place
it in the libkcore library.
Please apply, thanks,
Henning
Hello,
Four new kamailio modules now compile with the sr core:
* pv (Converted by Daniel)
* domain
* permissions
* perl
* perlvdb
I've also fixed the search_next_avp issue in acc module reported by Ovidiu, so
I marked it as OK again in the wiki.
Jan.
Module: sip-router
Branch: master
Commit: 346a9a0551e546189048d379ebe1f630db910d7c
URL: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commit;h=346a9a0…
Author: Jan Janak <jan(a)iptel.org>
Committer: Jan Janak <jan(a)iptel.org>
Date: Tue Mar 31 02:47:44 2009 +0200
Shared memory versions of mk_proxy and free_proxy.
This patch adds function mk_shm_proxy, which is the shared memory
version of function mk_proxy. In addition to that it adds function
free_shm_proxy which is the shared memory version of free_proxy.
To avoid code duplication, we turned the body of the original
hostent_cpy function into macro called HOSTENT_CPY, the macro takes
malloc and free functions as parameters. The macro is then called in
the body of hostent_cpy with pkg_malloc and pkg_free as parameters and
in the body of hostent_shm_cpy with shm_malloc and shm_free as
parameters.
We did the same to mk_proxy function. The original body of the function
was converted into macro MK_PROXY which, again, takes memory allocation
functions as we all the hostent copy function as parameters.
---
proxy.c | 284 ++++++++++++++++++++++++++++++++++++--------------------------
proxy.h | 2 +
2 files changed, 167 insertions(+), 119 deletions(-)
Diff: http://git.sip-router.org/cgi-bin/gitweb.cgi/sip-router/?a=commitdiff;h=346…