Daniel-Constantin Mierla writes:
wouldn't be better to have this function named: watcher_auth_status() (or ps_auth_status() - ps from presence server, or other prefix like pres, presence)? It will be more suggestive about provided functionality.
presence module has in its api a function called 'get_auth_status'. i just more or less reused the name so if someone reads presence module readme, he/she can easily associate those two.
-- juha