Hello,
the topic was discussed before a bit. My opinion was that with current content in the module, the name is ok.
It is not a generic connector for a message queue, but has wrapper functions that work on top of presence modules to exchange messages via a message queue.
I think that the module can be eventually split in a generic what-so-ever message queue, then kazoo stays only with the wrapper functions needed to build messages and spread them to other kazoo instances, binding internally to the new message queue module to use it for sending/receiving.
But it is too late for 4.2 to start moving a lot of code around. Should be a goal for the following major release.
Cheers, Daniel
On 17/09/14 12:32, Olle E. Johansson wrote:
Hi!
I am not sure I think Kazoo is a good name for the new module. It's a cool name, I agree on that...
For databases we have a prefix of db_ and ndb_.
We can get more modules using other message systems - like the OpenWRT message bus or OpenAIS (or even XMPP).
Maybe we should already set the name standard - mq_kazoo or mq_amqp ?
Yes I know I'm booooooring - but it makes some sort of sense.
If so, should we rename DMQ to mq_SIP ?
/O _______________________________________________ sr-dev mailing list sr-dev@lists.sip-router.org http://lists.sip-router.org/cgi-bin/mailman/listinfo/sr-dev