miconda left a comment (kamailio/kamailio#4221)
Thanks for the PR!
It would be good to keep coherence for local variable naming style, e.g., using lowercase -- now there are `Result` and `len`, or `FullBuffer` and `totallen`, or `sizeToAllocate`.
Also, declare the variables at the beginning of the block (e.g., `size_t name_len = strlen(dir->d_name);` is in the middle).