At the first sight, it looks good overall, just few changes that I would suggest:
* I think it would be better to name the new core parameter `ksr_tcp_accept_haproxy` instead of `ksr_tcp_accept_proxy`. The `proxy` term is also used in SIP a lot (Kamailio being a proxy itself), so I think using `haproxy` is more suggestive for the purpose of the parameter.
* there are couple of local variables when parsing the PROXY header which are not declared at the beginning of a block (or at the beginning of a function). Latest C compilers do not complain about, but we prefer to stay a bit more strict compliant with older specs in order to have it working on some embedded devices or old distros.