The commits for new features should not be mixed with changes for formatting or renaming of functions/macros in existing code, because it is not easy to review what are the actual new additions. Please rework the changes and make a commit dedicated only to the new feature.
Moreover, LM_* macros are also new ones that prefix the log messages with function name, etc... no need to change those macros at all. If we decide to replace/remove them, then it will be easier to do substituttion on a LM_XYZ than on XYZ.