Thank you @zenichev. I've given another read at the changes on tsilo and, as for tm changes, I think that there is a lot of duplicated code between ts_append/ts_append_by_contact and ts_append_to/ts_append_by_contact. E.g. the only diffrerence between ts_append_to and ts_append_by_contact_to is just the way tm's t_append branches is called (with or without contact). I think that it could be cleaner to expand the current functions' signature to add an optional contact.