Hey...
When you call a cisco 7960 f.eks. you see a text string with the name
of a user. .. Is it possible "hook" ser upto a database, witch contains
the whole phonecatalog. then make ser lookup a number, then put it into
the realname feeld ?
- Atle
Hi all
I have seen much doubt on using SER with RTPPROXY, also mine.
Already it sends some questions and I did not obtain to decide my problem.
UA(192.x.x.x) -----> SIP --------> UA 10.0x0x0
My archive of log (var/log/message) returns the error:
++++++++++++++++++++ ERROR +++++++++++++++++++++++++++++ /var/log/message
Feb 27 18:09:47 blacksip ser[3588 ]: ERROR: send_rtpp_command: can't read
reply from the RTP proxy
Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: send_rtpp_command: can't read
reply from the RTP proxy
Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: on_reply processing failed
++++++++++++++++++++ ERROR +++++++++++++++++++++++
I am certain that it has a good will of the members in helping those that
they are initiating.
I suggest that the Mrs Jiri and Klaus, write one mini How You of as to place
SER/RTPPROXY being functioned.
Thank You
João Carlos Moura
NiNeTel Telecommunications
+55 85 264-9039
Hi,
In the way that it is possible to use log(1, "message..."), is it possible
to log the value of the uri variable ??
Regards,
Alan
-------------------------------------------------------------------------------------------------------
This email, and any files transmitted with it, is copyright and may contain confidential information.
The contents are intended for the use of the addressee(s) only.
Unauthorized use may be unlawful.
If you receive this email by mistake, please advise sender immediately.
The views of the author may not necessarily constitute the views of Telco Electronics Limited.
Nothing in this mail shall bind Telco Electronics Limited in any contract or obligation.
Telco Electronics Limited
6-8 Oxford Court
Brackley
Northants
NN13 7XY
Tel 07000 701999
Fax 07000 701777
Hey guys.
anybody had the problem that the acc.so module just logs the INVITE to
the database? when I try to dial 0.. etc..
- Atle
#ACC stuff
modparam("acc", "log_level", 3)
modparam("acc", "log_flag", 12)
modparam("acc", "log_missed_flag", 22)
#ACC DB STUFF
modparam("acc", "db_url", "mysql://ser:heslo@localhost/ser")
modparam("acc", "db_flag", 1)
modparam("acc", "db_missed_flag", 31)
# ------------------------- request routing logic -------------------
# main routing logic
route{
if (uri=~"sip:0[0-9][3.5]*") { # ... it is for the peer site
strip(1);
setflag(1);
rewritehostport("192.168.11.5");
t_relay();
break;
};
Dear sir:
I am using a Cisco 3660 router as a SIP-PSTN gateway with my SER server.When I have configure all the thing has the guideline,I meet a problem.If I use a telephone call my MSN Messager or use MSN Messager call the telephone,the receiver could ring,and the MSN Messager could send and receive signal,but the telephone could only receive.In other words,the RTP packages could not send to UA at computers from the router.Does anyone can help me?
This is the configure at SER server:
# ------------------ module loading ----------------------------------
loadmodule "modules/sl/sl.so"
loadmodule "modules/tm/tm.so"
loadmodule "modules/acc/acc.so"
loadmodule "modules/rr/rr.so"
loadmodule "modules/maxfwd/maxfwd.so"
loadmodule "modules/mysql/mysql.so"
loadmodule "modules/auth/auth.so"
loadmodule "modules/auth_db/auth_db.so"
loadmodule "modules/group/group.so"
loadmodule "modules/uri/uri.so"
# ----------------- setting module-specific parameters ---------------
modparam("auth_db", "db_url","sql://ser:heslo@localhost/ser")
modparam("auth_db", "calculate_ha1", yes)
modparam("auth_db", "password_column", "password")
# -- acc params --
modparam("acc", "log_level", 1)
# that is the flag for which we will account -- don't forget to
# set the same one :-)
modparam("acc", "log_flag", 1 )
# ------------------------- request routing logic -------------------
# main routing logic
route{
/* ********* ROUTINE CHECKS ********************************** */
# filter too old messages
if (!mf_process_maxfwd_header("10")) {
log("LOG: Too many hops\n");
sl_send_reply("483","Too Many Hops");
break;
};
if (len_gt( max_len )) {
sl_send_reply("513", "Wow -- Message too large");
break;
};
/* ********* RR ********************************** */
/* grant Route routing if route headers present */
if (loose_route()) { t_relay(); break; };
/* record-route INVITEs -- all subsequent requests must visit us */
if (method=="INVITE") {
record_route();
};
# now check if it really is a PSTN destination which should be handled
# by our gateway; if not, and the request is an invitation, drop it --
# we cannot terminate it in PSTN; relay non-INVITE requests -- it may
# be for example BYEs sent by gateway to call originator
if (!uri=~"sip:\+?[0-9]+@.*") {
if (method=="INVITE") {
sl_send_reply("403", "Call cannot be served here");
} else {
forward(uri:host, uri:port);
};
break;
};
# account completed transactions via syslog
setflag(1);
# free call destinations ... no authentication needed
if ( is_user_in("Request-URI", "free-pstn") /* free destinations */
| uri=~"sip:[79][0-9][0-9][0-9]@.*" /* local PBX */
| uri=~"sip:98[0-9][0-9][0-9][0-9]") {
log("free call");
} else if (src_ip==192.168.0.10) {
# our gateway doesn't support digest authentication;
# verify that a request is coming from it by source
# address
log("gateway-originated request");
} else {
# in all other cases, we need to check the request against
# access control lists; first of all, verify request
# originator's identity
if (!proxy_authorize( "gateway" /* realm */,
"subscriber" /* table name */)) {
proxy_challenge( "gateway" /* realm */, "0" /* no qop */ );
break;
};
# authorize only for INVITEs -- RR/Contact may result in weird
# things showing up in d-uri that would break our logic; our
# major concern is INVITE which causes PSTN costs
if (method=="INVITE") {
# does the authenticated user have a permission for local
# calls (destinations beginning with a single zero)?
# (i.e., is he in the "local" group?)
if (uri=~"sip:0[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "local")) {
sl_send_reply("403", "No permission for local calls");
break;
};
# the same for long-distance (destinations begin with two zeros")
} else if (uri=~"sip:00[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "ld")) {
sl_send_reply("403", " no permission for LD ");
break;
};
# the same for international calls (three zeros)
} else if (uri=~"sip:000[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "int")) {
sl_send_reply("403", "International permissions needed");
break;
};
# everything else (e.g., interplanetary calls) is denied
} else {
sl_send_reply("403", "Forbidden");
break;
};
}; # INVITE to authorized PSTN
}; # authorized PSTN
# if you have passed through all the checks, let your call go to GW!
rewritehostport("192.168.0.10:5060");
# forward the request now
if (!t_relay()) {
sl_reply_error();
break;
};
}
And this is the configure at the Cisco 3660:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SIP
!
enable secret 5 $1$Ov6R$SoCYqYuzY7a7spMUSEz2e.
enable password 123456
!
ip subnet-zero
no ip routing
!
!
ip name-server 162.105.170.66
ip name-server 162.105.129.27
!
!
voice rtp send-recv
!
voice service pots
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g729br8
codec preference 13 g711ulaw
codec preference 14 g711alaw
!
voice class codec 13
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.200 255.255.255.0
no ip route-cache
no ip mroute-cache
speed auto
half-duplex
no cdp enable
!
interface FastEthernet0/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial3/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/2
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/3
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface FastEthernet5/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial5/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet5/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial5/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet6/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial6/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet6/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial6/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface Dialer1
no ip address
!
ip default-gateway 192.168.0.1
ip classless
no ip http server
ip pim bidir-enable
!
!
vc-group 1
!
snmp-server community public RO
!
call rsvp-sync
!
voice-port 1/0/0
cptone CN
description 3078
supervisory disconnect dualtone mid-call
!
voice-port 1/0/1
!
voice-port 1/1/0
cptone CN
description 3078
supervisory disconnect dualtone mid-call
!
voice-port 1/1/1
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 86100 pots
application session
destination-pattern 8610T
port 1/0/0
!
dial-peer voice 1000 voip
application session
destination-pattern .T
session protocol sipv2
session target sip-server
session transport udp
codec g711ulaw
!
dial-peer voice 100 pots
destination-pattern 010T
port 1/0/0
!
dial-peer voice 86000 pots
destination-pattern 8600T
port 1/1/0
!
sip-ua
timers disconnect 200
sip-server dns:sipproxy.icst.pku.edu.cn
!
!
line con 0
line aux 0
line vty 0 4
password 123456
login
!
!
end
hi,
I want to know if there is any complete documentation about SER
scripts... Type definition, pointers, arrays ( to declare an array with
several uris ) or struct.... I've read the cfg.y file but i didn't
understand much...
Maybe the best way to process these kinds of types is using a module...
thx,
Laurent
Dear sir:
I am using a Cisco 3660 router as a SIP-PSTN gateway with my SER server.When I have configure all the thing has the guideline,I meet a problem.If I use a telephone call my MSN Messager or use MSN Messager call the telephone,the receiver could ring,and the MSN Messager could send and receive signal,but the telephone could only receive.In other words,the RTP packages could not send to UA at computers from the router.Does anyone can help me?
This is the configure at SER server:
# ------------------ module loading ----------------------------------
loadmodule "modules/sl/sl.so"
loadmodule "modules/tm/tm.so"
loadmodule "modules/acc/acc.so"
loadmodule "modules/rr/rr.so"
loadmodule "modules/maxfwd/maxfwd.so"
loadmodule "modules/mysql/mysql.so"
loadmodule "modules/auth/auth.so"
loadmodule "modules/auth_db/auth_db.so"
loadmodule "modules/group/group.so"
loadmodule "modules/uri/uri.so"
# ----------------- setting module-specific parameters ---------------
modparam("auth_db", "db_url","sql://ser:heslo@localhost/ser")
modparam("auth_db", "calculate_ha1", yes)
modparam("auth_db", "password_column", "password")
# -- acc params --
modparam("acc", "log_level", 1)
# that is the flag for which we will account -- don't forget to
# set the same one :-)
modparam("acc", "log_flag", 1 )
# ------------------------- request routing logic -------------------
# main routing logic
route{
/* ********* ROUTINE CHECKS ********************************** */
# filter too old messages
if (!mf_process_maxfwd_header("10")) {
log("LOG: Too many hops\n");
sl_send_reply("483","Too Many Hops");
break;
};
if (len_gt( max_len )) {
sl_send_reply("513", "Wow -- Message too large");
break;
};
/* ********* RR ********************************** */
/* grant Route routing if route headers present */
if (loose_route()) { t_relay(); break; };
/* record-route INVITEs -- all subsequent requests must visit us */
if (method=="INVITE") {
record_route();
};
# now check if it really is a PSTN destination which should be handled
# by our gateway; if not, and the request is an invitation, drop it --
# we cannot terminate it in PSTN; relay non-INVITE requests -- it may
# be for example BYEs sent by gateway to call originator
if (!uri=~"sip:\+?[0-9]+@.*") {
if (method=="INVITE") {
sl_send_reply("403", "Call cannot be served here");
} else {
forward(uri:host, uri:port);
};
break;
};
# account completed transactions via syslog
setflag(1);
# free call destinations ... no authentication needed
if ( is_user_in("Request-URI", "free-pstn") /* free destinations */
| uri=~"sip:[79][0-9][0-9][0-9]@.*" /* local PBX */
| uri=~"sip:98[0-9][0-9][0-9][0-9]") {
log("free call");
} else if (src_ip==192.168.0.10) {
# our gateway doesn't support digest authentication;
# verify that a request is coming from it by source
# address
log("gateway-originated request");
} else {
# in all other cases, we need to check the request against
# access control lists; first of all, verify request
# originator's identity
if (!proxy_authorize( "gateway" /* realm */,
"subscriber" /* table name */)) {
proxy_challenge( "gateway" /* realm */, "0" /* no qop */ );
break;
};
# authorize only for INVITEs -- RR/Contact may result in weird
# things showing up in d-uri that would break our logic; our
# major concern is INVITE which causes PSTN costs
if (method=="INVITE") {
# does the authenticated user have a permission for local
# calls (destinations beginning with a single zero)?
# (i.e., is he in the "local" group?)
if (uri=~"sip:0[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "local")) {
sl_send_reply("403", "No permission for local calls");
break;
};
# the same for long-distance (destinations begin with two zeros")
} else if (uri=~"sip:00[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "ld")) {
sl_send_reply("403", " no permission for LD ");
break;
};
# the same for international calls (three zeros)
} else if (uri=~"sip:000[1-9][0-9]+@.*") {
if (!is_user_in("credentials", "int")) {
sl_send_reply("403", "International permissions needed");
break;
};
# everything else (e.g., interplanetary calls) is denied
} else {
sl_send_reply("403", "Forbidden");
break;
};
}; # INVITE to authorized PSTN
}; # authorized PSTN
# if you have passed through all the checks, let your call go to GW!
rewritehostport("192.168.0.10:5060");
# forward the request now
if (!t_relay()) {
sl_reply_error();
break;
};
}
And this is the configure at the Cisco 3660:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SIP
!
enable secret 5 $1$Ov6R$SoCYqYuzY7a7spMUSEz2e.
enable password 123456
!
ip subnet-zero
no ip routing
!
!
ip name-server 162.105.170.66
ip name-server 162.105.129.27
!
!
voice rtp send-recv
!
voice service pots
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g729br8
codec preference 13 g711ulaw
codec preference 14 g711alaw
!
voice class codec 13
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.200 255.255.255.0
no ip route-cache
no ip mroute-cache
speed auto
half-duplex
no cdp enable
!
interface FastEthernet0/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial3/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/2
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface Serial3/3
no ip address
no ip route-cache
no ip mroute-cache
shutdown
serial restart_delay 0
no cdp enable
!
interface FastEthernet5/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial5/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet5/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial5/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet6/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial6/0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface FastEthernet6/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial6/1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
clockrate 2000000
no cdp enable
!
interface Dialer1
no ip address
!
ip default-gateway 192.168.0.1
ip classless
no ip http server
ip pim bidir-enable
!
!
vc-group 1
!
snmp-server community public RO
!
call rsvp-sync
!
voice-port 1/0/0
cptone CN
description 3078
supervisory disconnect dualtone mid-call
!
voice-port 1/0/1
!
voice-port 1/1/0
cptone CN
description 3078
supervisory disconnect dualtone mid-call
!
voice-port 1/1/1
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 86100 pots
application session
destination-pattern 8610T
port 1/0/0
!
dial-peer voice 1000 voip
application session
destination-pattern .T
session protocol sipv2
session target sip-server
session transport udp
codec g711ulaw
!
dial-peer voice 100 pots
destination-pattern 010T
port 1/0/0
!
dial-peer voice 86000 pots
destination-pattern 8600T
port 1/1/0
!
sip-ua
timers disconnect 200
sip-server dns:sipproxy.icst.pku.edu.cn
!
!
line con 0
line aux 0
line vty 0 4
password 123456
login
!
!
end
Hi Again,
Does SER support queries to DNS SRV?Yes?No?
If yes.How can we do to configure it that way?
Thanks,
Toni
-----Original Message-----
From: Toni Barata [mailto:toni-r-barata@ptinovacao.pt]
Sent: quarta-feira, 25 de Fevereiro de 2004 17:21
To: 'serusers(a)lists.iptel.org'
Subject: [Serusers] DNS SRV
Hi All,
In case we pretend to proxy the messages from SER to multiple Media Servers,
it is possible to use DNS SRV for load balancing and fault tolerance?
We have already one implementation of load balancing e fault tolerance for
SER (using DNS SRV) but now we want to implement the same configuration for
ours Media Servers.
Best regards,
Toni
Hi,
I have that to implement in my company a solution VOIP.
I am testing SER/RTPProxy. My problem is in the call of the equipment with
IP 192.168.0.20 for another side with IP 200.2xx.xx.xx.
In the archive /var/log/message, has the error message
++++++++++++++++++++ ERROR +++++++++++++++++++++++++++++
/var/log/message
Feb 27 18:09:47 blacksip ser[3588 ]: ERROR: send_rtpp_command: can't
read
reply from the RTP proxy
Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: send_rtpp_command: can't
read
reply from the RTP proxy
Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: on_reply processing failed
++++++++++++++++++++ ERROR +++++++++++++++++++++++
The project that I intend to implant is similar to the FWD.
The version that I am using is: CVS SER 0.8.12-TCP_nonb (i386/linux)
CVS rtpproxy 20040107
Athlon 1900+ / 256Mb / 40GB HD
REDHat 9.0
Thank You
João Carlos Moura
Hi Joao!
You should ask your questions to the mailing list which were setup for
these problems. You can subscribe at:
http://lists.iptel.org/mailman/listinfo/serusers
And then you should send your questions to serusers(a)lists.iptel.org
These versions should work fine. Are you using the original 0.8.12
release or have you used CVS to retrieve 0.8.12?
There were some updates to the nathelper module which are not in the
original 0.8.12 release, but in the CVS rel_0_8_12. You should donwload
from cvs, compile ser again and try again.
Klaus
Joao Carlos Moura wrote:
> Hi Mr. Klaus,
>
> Thank you for helping me
>
> Pardon, really more necessary of help
>
> The version that I am using is: SER 0.8.12-TCP_nonb (i386/linux)
> rtpproxy 20040107
>
> Athlon 1900+ / 256Mb / 40GB HD
> REDHat 9.0
>
> My archive of log (var/log/message) returns the error:
> ++++++++++++++++++++ ERROR +++++++++++++++++++++++++++++ /var/log/message
> Feb 27 18:09:47 blacksip ser[3588 ]: ERROR: send_rtpp_command: can't read
> reply from the RTP proxy
> Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: send_rtpp_command: can't read
> reply from the RTP proxy
> Feb 27 18:09:58 blacksip ser[3586 ]: ERROR: on_reply processing failed
> ++++++++++++++++++++ ERROR +++++++++++++++++++++++
>
> Thank You
>
> João Carlos Moura
> NiNeTel Telecommunications
> +55 85 264-9039
>
>
>