HI I just did simple test-case: add user and delete user on kamailio 3.3 on 101 , I added 103, the watcher tables shows: select * from watchers; +----+------------------------+------------------+----------------+----------+--------+--------+---------------+ | id | presentity_uri | watcher_username | watcher_domain | event | status | reason | inserted_time | +----+------------------------+------------------+----------------+----------+--------+--------+---------------+ | 1 | sip:103@192.168.122.32 | 101 | 192.168.122.32 | presence | 2 | | 1339772803 | +----+------------------------+------------------+----------------+----------+--------+--------+---------------+ then I deleted the 103 from the contact list, the watcher table still shows the same. It seems a strange behavior, should this to be deleted from the db? what's the expected behavior on the watchers table for delete/adding user? In my previos email testing case, there is terminated status=3 in db, when will this item will be deleted? http://lists.sip-router.org/pipermail/sr-users/2012-June/073621.html From the http://tools.ietf.org/html/rfc3857#section-4.7.1, there is nowhere to go if it it is in the terminated status. subscribe, policy= +----------+ reject | |<------------------------+ +------------>|terminated|<---------+ | | | | | | | | | |noresource | | +----------+ |rejected | | ^noresource |deactivated | | |rejected |probation | | |deactivated |timeout |noresource | |probation | |rejected | |giveup | |giveup | | | |approved +-------+ +-------+ +-------+ | | |subscribe| |approved| | | | init |-------->|pending|------->|active | | | |no policy| | | | | | | | | | | | +-------+ +-------+ +-------+ | | | ^ | | subscribe, | | | +-----------------------------------+ | policy = accept | +-------+ | | | | | | |waiting|----------+ +----------->| | timeout | | +-------+ Figure 1: Subscription State Machine just FYI, there were some discussions before regarding the deletion, state machine. http://sip-router.org/tracker/index.php?do=details&task_id=133 http://lists.opensips.org/pipermail/devel/2009-August/003868.html min